Website availability issues
Incident Report for Bugsnag
Resolved
This incident has been resolved.
Posted over 1 year ago. May 22, 2017 - 20:27 UTC
Investigating
We are investigating timeouts affecting the dashboard and data access API.
Posted over 1 year ago. May 22, 2017 - 20:17 UTC